The complete automotive resource for buyers, sellers, and owners like you.
Car, Truck and SUV Forums at Roadfly
+ Bentley Forums
+ BMW Forums
+ Cadillac Forums
+ Chevrolet Forums
+ Ferrari Forums
+ Jaguar Forums
+ Lamborghini Forums
+ Lotus Forums
+ Mercedes-Benz Forums
+ Maserati Forums
+ MINI Forums
+ Porsche Forums
+ General Discussion
+ Marketplace Forums
Pre-engine swap cold feet/questions (archive)

[ Follow Ups ] [ 2002 Message Board ] [ Msg. Board FAQ ]

Posted by Alan on March 09, 2000 at 23:38:33:

Looks like the motor from my 320 is getting swapped tommorow or the next day. Got my 32/36 almost all the way rebuilt/polished, matched the intake to the carb (thanks for the rotary rasp suggestions, it was a piece of cake) Electric fuel pump is in, but for some reason, no fuel is making it up to the engine compartment. I know the thing pumps fuel, my trunk still stinks like gas. Should I be checking for obstructions in the hose? Could the pump be weak? Also, how do I secure my 320i radiator on the 02? it's the BEHR one with the plastic top, and it's brand new and shiny, so I pulled it out. It was installed in the 320 with 2 bolts/spacers on the top. Looks like those won't work in the 02. So do I drill 4 holes and use bolts there? Getting close, I'm getting excited, and finding more and more little things I meant to fix beforehand. . . oh well. TIA everyone
-alan
74 02
79 320i


Follow Ups:



[ Follow Ups ] [ 2002 Message Board ] [ Msg. Board FAQ ]
Questions, comments, or problems, please visit the Roadfly help desk.
Roadfly.com Logo © 1997 - 2017 Jump Internet Inc. All rights reserved.