The complete automotive resource for buyers, sellers, and owners like you.
Car, Truck and SUV Forums at Roadfly
+ Bentley Forums
+ BMW Forums
+ Cadillac Forums
+ Chevrolet Forums
+ Ferrari Forums
+ Jaguar Forums
+ Lamborghini Forums
+ Lotus Forums
+ Mercedes-Benz Forums
+ Maserati Forums
+ MINI Forums
+ Porsche Forums
+ General Discussion
+ Marketplace Forums
Re: 74 Tii runs great cold, lousy warm?? (archive)

[ Follow Ups ] [ 2002 Message Board ] [ Msg. Board FAQ ]

Posted by Mark Hammons on April 27, 2000 at 11:48:52:

In Reply to: 74 Tii runs great cold, lousy warm?? posted by peterrod on April 26, 2000 at 15:40:39:

: My 74 tii runs fine when cold. No hesitation etc. When the engine gets to normal operating temp, its starts to hesitate-almost feels like fuel starvation. Could this be a mis adjusted warm up regulator? If so how do I adjust to run beeter when warm? Check archives already.

: I have new fuel pump, hoses, gas tank, cleaned the damper valve, new plugs, points, dist. cap etc.
: Any thoughts. As always, TIA.
: Peter

I have a 74tii also. Make sure that the warmup regulator is working when the engine warms up. The "Hat" that pulls down the richening lever should not be touching the lever when the engine is warmed up. If it is then maybe the regulator is not operating or not getting warm coolant flowing through it.

I had the opposite problem where the engine was running crummy cold but was fine warm. Turned out that my warmup regulator was set too rich.


Follow Ups:



[ Follow Ups ] [ 2002 Message Board ] [ Msg. Board FAQ ]
Questions, comments, or problems, please visit the Roadfly help desk.
Roadfly.com Logo © 1997 - 2017 Jump Internet Inc. All rights reserved.