The complete automotive resource for buyers, sellers, and owners like you.
Car, Truck and SUV Forums at Roadfly
+ Bentley Forums
+ BMW Forums
+ Cadillac Forums
+ Chevrolet Forums
+ Ferrari Forums
+ Jaguar Forums
+ Lamborghini Forums
+ Lotus Forums
+ Mercedes-Benz Forums
+ Maserati Forums
+ MINI Forums
+ Porsche Forums
+ General Discussion
+ Marketplace Forums
Re: what did i do to my k-fisher?? (long) (archive)

[ Follow Ups ] [ 2002 Message Board ] [ Msg. Board FAQ ]

Posted by MitchM on June 26, 2001 at 10:14:13:

In Reply to: what did i do to my k-fisher?? (long) posted by tim on June 25, 2001 at 21:48:27:


i replace the O-rings on my k-fisher yesterday. now my 02 is running very poorly and (worst of all) i don't know why.
it's sputtering and running very rough - almost like one of the cylinders isn't firing or not getting the right fuel mix. i thought that maybe one of the plugs were fouled so i replaced them but still not fixed.
up to yesterday it was running great. the only thing that i did was to replace those O-rings so I got to thinking that I did something to the k-fisher when i was playing around with the float valves. i didn't do anything extreme just poked at them a bit with a small screwdriver to see what they looked like. i didn't do anything bizarre and i'm pretty sure i put it back the way it was. i reopened all four of the hex-headed bolts tonight to see if any of the float valves were turned sideways or something but all looked OK to me.
any ideas? i tried to make sure that i kept anything magnatized away from the whole thing while i was working on it.
it's got me pretty confused and disappointed at the moment -my baby was running great before this.
what do you think? any thoughts on what i may have done that is causing this rough running? i can only think that it's something to do with the float valves and/or hex-headed bolts. is it possible that one of the valves can be turned upside down somehow? the float valves and hex-headed bolts were really the only thing that i touched between my baby running great and running rough.
any insights?
i appreciate any thoughts anyone can offer. thanks again for all the advice.
tim
72 tii

Sounds like you may have knocked some fine dirt or something into the pump. On my car, I changed the O-rings when they were leaking, and that was it. The insides of the pump are off-limits, unless you're going to overhaul the thing and have several extras lying around (or if you're Dave Redsus). Messin mit das pump ist streng Verboten!



Follow Ups:



[ Follow Ups ] [ 2002 Message Board ] [ Msg. Board FAQ ]
Questions, comments, or problems, please visit the Roadfly help desk.
Roadfly.com Logo © 1997 - 2017 Jump Internet Inc. All rights reserved.