The complete automotive resource for buyers, sellers, and owners like you.
Car, Truck and SUV Forums at Roadfly
+ Bentley Forums
+ BMW Forums
+ Cadillac Forums
+ Chevrolet Forums
+ Ferrari Forums
+ Jaguar Forums
+ Lamborghini Forums
+ Lotus Forums
+ Mercedes-Benz Forums
+ Maserati Forums
+ MINI Forums
+ Porsche Forums
+ General Discussion
+ Marketplace Forums
Weird Electrical Problem! (archive)

[ Follow Ups ] [ 2002 Message Board ] [ Msg. Board FAQ ]

Posted by dahveed on June 27, 2001 at 02:34:08:

I recently posted about having a 318i alt. and the timing cover stud shearing off. What I did was replace the stud again with a new stock piece, kept the same alt., but I had a 2002 alternator adjusting bracket bent for the offset and installed instead of the 318i piece I was using.

The narrower stock piece places the load on the base of the stud, where it goes into the timing cover.

The 318i adjuster arm has a wide boss and can possibly spread the load to the front of the stud by having a wider load surface.

I've got my fingers crossed that this will work!

I just noticed again that my car has a strange electrical gremlin that first reared its head before the timing cover stud broke.

When the engine is running, my foot is on the brake pedal, and then I turn the key to the off position, the engine still runs. I can even remove the key. Once I take my foot off the brake, the engine finally cuts out. If I put my foot on the brake, with the key in the off position or removed, the red alt. light turns on along with the gas gauge.

I can't understand what would cause this??

Dave Savell
'68 1600-2


Follow Ups:



[ Follow Ups ] [ 2002 Message Board ] [ Msg. Board FAQ ]
Questions, comments, or problems, please visit the Roadfly help desk.
Roadfly.com Logo © 1997 - 2017 Jump Internet Inc. All rights reserved.