The complete automotive resource for buyers, sellers, and owners like you.
Car, Truck and SUV Forums at Roadfly
+ Bentley Forums
+ BMW Forums
+ Cadillac Forums
+ Chevrolet Forums
+ Ferrari Forums
+ Jaguar Forums
+ Lamborghini Forums
+ Lotus Forums
+ Mercedes-Benz Forums
+ Maserati Forums
+ MINI Forums
+ Porsche Forums
+ General Discussion
+ Marketplace Forums
HELP! New (to me) 525ia (archive)

[ Follow Ups ] [ BMW 5-series Message Board ] [ Msg. Board FAQ ]

Posted by Fast Eddie on September 22, 1998 at 14:44:35:

I'm new to BMW (less than 1 week with a '91 525iA, 77,000 mi.), but not new to the automotive world (I race Porsches in PCA racing...). I was hoping that the group could provide some expert guidance on my new find.

First, is there an aftermarket manual that would suffice for light to medium services (up to removing the head as well as servicing accessory components -- water pump, etc...)? Haynes comes to mind, NOTchilton.

Second, some questions specific to this car.

1) I get a "Coolant Level" warning from the display, yet coolant level seems normal (just above the "max" mark and I don't think its losing coolant). Is there such a thing as too much coolant causing this reading? Could the sensor float in the expansion tank have sprung a leak and sunk, thereby making/losing contact and causing the warning? If so, how difficult or expensive is it to replace the unit and how would one go about doing so. (I'm assuming that one simply unscrews the sensor from the bottom of the expansion tank to replace it.) I saw an earlier posting regarding this issue, but it was unclear as to the exact fix.

2) I have a slight surge at idle and a stronger surge when accelerating. I'm sure its the same thing, just more pronounced when accelerating. It is most noticeable at part throttle in second gear and one can see the MPG gauge (what the heck is that gauge for anyway...) moving up and down with the surge. It is definitely not from transmission slippage. Also, sometimes when the car is started, it revs (without any throttle input on my part) to about 2,500 before settling at about 600. Help! What could this be and how would one correct the problem?

3) Idle is a bit rough sometimes. This is not cam, but rather some type of intermittant miss. It runs smoothly, but falters from time to time. Seems to be worse when cold?

4) There is some front wheel hop when turning right while traversing an uneven road surface (hitting a bump). I get some shake through the steering wheel and I think its isolated to the r/h side. Worn strut perhaps...? It feels a bit like "cowl shake" I used to have in a flexy MGB or bump steer I have from the lowered race car. There is no pull under braking or hop (shimmy) when accelerating in a straight line at any speed.

5) There is an oil leak somewhere in the front of the engine. I've cleaned the front and bottom of the engine in anticipation of determining where it is coming from. My mechanic says front crank seal, but rather than pulling the front of the engine off to replace a $2 seal, I was wondering whether there might be some other cause?

I love this car (already) and think it has a lot of potential. The body is in great shape (no accident damage or rust) and the interior is pretty good. I'm looking forward to many years of enjoying this car. Thanks, I greatly appreciate your help and anticipate your responses.

Regards,

Edward Moore
[email protected]


Follow Ups:



[ Follow Ups ] [ BMW 5-series Message Board ] [ Msg. Board FAQ ]
Questions, comments, or problems, please visit the Roadfly help desk.
Roadfly.com Logo © 1997 - 2016 Jump Internet Inc. All rights reserved.