The complete automotive resource for buyers, sellers, and owners like you.
Car, Truck and SUV Forums at Roadfly
+ Bentley Forums
+ BMW Forums
+ Cadillac Forums
+ Chevrolet Forums
+ Ferrari Forums
+ Jaguar Forums
+ Lamborghini Forums
+ Lotus Forums
+ Mercedes-Benz Forums
+ Maserati Forums
+ MINI Forums
+ Porsche Forums
+ General Discussion
+ Marketplace Forums
Re: AFM testing (SOS)!!!!!!!!! (archive)

[ Follow Ups ] [ 5-series (E28) Message Board ] [ Msg. Board FAQ ]

Posted by Marcus on January 08, 2001 at 19:14:52:

In Reply to: AFM testing (SOS)!!!!!!!!! posted by Artem Grigortyev on January 08, 2001 at 15:47:12:

I had a similar (if not identical) problem a few months ago. Try resetting the computer by disconnecting the battery and then reconnecting it. THat was the main problem (it gets out of spec and can't reset) but the AFM also needed adjustment. Can you hear any backfire or misfire.??)
My 535i 86 is about to die again. Before, when you would accelerate, the engine cut out for a second (which was accompanied with a nice jerk!) but then it would keep going again. For some reason, I also didn't have any power. Now it is acting even worse. Even in neutral (5sp manual), when you push the accelerator, you have to wait until it would actually rev up. Needless to say that it is not accelerating at all (Takes forever starting on 1st). What is interesting if you get beyond 3000 rpm it actually starts accelerating. May be it is my AFM? I got it here and the flapper door seems to move smoothly. Can I check for resistance?

Lately I replaced airfilter, spark plugs, fuel filter and fuel pressure regulator.

I have to get home somehow (right now I'm at work) and besides I'm working on my wife’s 528e (VALVE JOB!) so I don't really have time for this crap.

Any suggestions would be appreciated





Follow Ups:



[ Follow Ups ] [ 5-series (E28) Message Board ] [ Msg. Board FAQ ]
Questions, comments, or problems, please visit the Roadfly help desk.
Roadfly.com Logo © 1997 - 2017 Jump Internet Inc. All rights reserved.