The complete automotive resource for buyers, sellers, and owners like you.
Car, Truck and SUV Forums at Roadfly
+ Bentley Forums
+ BMW Forums
+ Cadillac Forums
+ Chevrolet Forums
+ Ferrari Forums
+ Jaguar Forums
+ Lamborghini Forums
+ Lotus Forums
+ Mercedes-Benz Forums
+ Maserati Forums
+ MINI Forums
+ Porsche Forums
+ General Discussion
+ Marketplace Forums
Thanks! (archive)

[ Follow Ups ] [ 5-series (E28) Message Board ] [ Msg. Board FAQ ]

Posted by Jason on January 08, 2001 at 22:39:52:

In Reply to: electrical problems and mysteries posted by Jason on January 08, 2001 at 12:34:36:

I have checked under the fuse box and cleaned/tested the ICV. Everything seems OK there. I did wiggle the wires that go into the harness for the ICU (unit above motronic) and the idle started oscillating between 600 and 1500 RPM, which tells me there is a bad connection in the wiring there.

On the lights on the instrument panel and battery problem, I took my 528 to AutoZone and they ran testing on it. They concluded it was the alternator (probably voltage regulator).

I will definitely clean the connections, especially grounds.

Thanks for all the help and replies. I hope it will take it all the way to the 200k mark and beyond. Although, I'm not holding my breath! The binding on my Bentley is already falling apart. I think I need to start a BMW budget.

BTW, here is a site I have found a lot of help in troubleshooting driveability problems:

http://www.geocities.com/bmw535i86/text/idle_FAQ.html

Jason




Follow Ups:



[ Follow Ups ] [ 5-series (E28) Message Board ] [ Msg. Board FAQ ]
Questions, comments, or problems, please visit the Roadfly help desk.
Roadfly.com Logo © 1997 - 2017 Jump Internet Inc. All rights reserved.