The complete automotive resource for buyers, sellers, and owners like you.
Car, Truck and SUV Forums at Roadfly
+ Bentley Forums
+ BMW Forums
+ Cadillac Forums
+ Chevrolet Forums
+ Ferrari Forums
+ Jaguar Forums
+ Lamborghini Forums
+ Lotus Forums
+ Mercedes-Benz Forums
+ Maserati Forums
+ MINI Forums
+ Porsche Forums
+ General Discussion
+ Marketplace Forums
Electrical Nightmare (archive)

[ Follow Ups ] [ 5-series (E28) Message Board ] [ Msg. Board FAQ ]

Posted by Mike Playle on February 04, 2001 at 00:17:15:

I have been a lurker in this forum for a while but enjoy the tips and help for some problems. I am a first time Bimmer owner and have a car that nost of you probably wont even consider a "real" BMW. My car is an 86 520I Automatic assembled in South Africa. Beleive me these are really sparse on extras. I have wind up windows,no heated seats, no electric antenna, no check light panel (just one lamp in the dash) no fog lights and the radio cassette from hell. Other thaan that the car has only done 33509 kms since new and drives like a gem. I have a 2000 Mitsi Galant with a tip tronic and still prefer the bimmer , Anyway heres my problem.

The car appears to drain the battery . After a long trip even it is slow to turn over but will start eventually. If left for 10-2 days the battery goes completely flat . I have tried new batteries but still the same. Aany help welcome

Thanks guys.

BTW I live in New Zealand anfd 520i is a popular model here

Does it still qualify as an E28

MIke
86 520i




Follow Ups:



[ Follow Ups ] [ 5-series (E28) Message Board ] [ Msg. Board FAQ ]
Questions, comments, or problems, please visit the Roadfly help desk.
Roadfly.com Logo © 1997 - 2017 Jump Internet Inc. All rights reserved.