The complete automotive resource for buyers, sellers, and owners like you.
Car, Truck and SUV Forums at Roadfly
+ Bentley Forums
+ BMW Forums
+ Cadillac Forums
+ Chevrolet Forums
+ Ferrari Forums
+ Jaguar Forums
+ Lamborghini Forums
+ Lotus Forums
+ Mercedes-Benz Forums
+ Maserati Forums
+ MINI Forums
+ Porsche Forums
+ General Discussion
+ Marketplace Forums
alternator not charging always (archive)

[ Follow Ups ] [ 5-series (E28) Message Board ] [ Msg. Board FAQ ]

Posted by andy on February 04, 2001 at 17:45:21:

Hi all,

got yet another issue:-) I was experiencing 'weak starting' and slow windows, etc, and discovered that the alternator is not always charging. I recharged battery and did the following:
1- attached voltmeter to battery (read about 12.8 volts with motor off)
2- checked current draw of off car (about 18mA. so probably no draining problem)
3- started car. Voltage drops to about 12.5, obviously alternator not charging.
4- rev'ed car a couple times. bingo, voltage (even at idle now) up to 14.0

sounds like the 'thingamabobs' in the alternator that should contact (upon 'spinning') aren't doing their job well. Once spun up, voltage appears stable even with headlights and accessories on. (don't have a high current tester...).

it's a 90amp alternator. years ago, I rebuilt quite a few chrysler alternators. Are kits available, or should I just not bother and get a new/rebuilt one?

AtDhVaAnNkCsE (that's thanks in advance)
andy


Follow Ups:



[ Follow Ups ] [ 5-series (E28) Message Board ] [ Msg. Board FAQ ]
Questions, comments, or problems, please visit the Roadfly help desk.
Roadfly.com Logo © 1997 - 2017 Jump Internet Inc. All rights reserved.