The complete automotive resource for buyers, sellers, and owners like you.
Car, Truck and SUV Forums at Roadfly
+ Bentley Forums
+ BMW Forums
+ Cadillac Forums
+ Chevrolet Forums
+ Ferrari Forums
+ Jaguar Forums
+ Lamborghini Forums
+ Lotus Forums
+ Mercedes-Benz Forums
+ Maserati Forums
+ MINI Forums
+ Porsche Forums
+ General Discussion
+ Marketplace Forums
Re: Ignition (archive)

[ Follow Ups ] [ E30 M3 Message Board ] [ Msg. Board FAQ ]

Posted by chuck waits on December 31, 1999 at 11:55:46:

In Reply to: Re: Ignition posted by Paul C. on December 19, 1999 at 08:08:36:

: : I am having problems with my ignition (engine turns off while driving and can be immediately turned back on) I was wondering if anyone has had this problem with their M3? Could it be the switch, a wire or even the box? I welcome any suggestions

:
: First place I'd check would be either the main or fuel pump relays behind the coolant overflow tank. This is a typical complaint when these go bad. Make sure you have the new white plastic main relay and not the original metal one.

i have had the same problem with my old 325 e30 it turned out to be the fusale link giong from the batery to the alternater.what would happen was when the car got hotter the link didnt burn but was broken by somthing in the trunk, so when the car would warm the wire would lose connection and the car would stall. You could crank it right back up when this happened but would almost die again ammediately. So i had the car serviced and i turned out to be a $15.00 wire


Follow Ups:



[ Follow Ups ] [ E30 M3 Message Board ] [ Msg. Board FAQ ]
Questions, comments, or problems, please visit the Roadfly help desk.
Roadfly.com Logo © 1997 - 2017 Jump Internet Inc. All rights reserved.