The complete automotive resource for buyers, sellers, and owners like you.
Car, Truck and SUV Forums at Roadfly
+ Bentley Forums
+ BMW Forums
+ Cadillac Forums
+ Chevrolet Forums
+ Ferrari Forums
+ Jaguar Forums
+ Lamborghini Forums
+ Lotus Forums
+ Mercedes-Benz Forums
+ Maserati Forums
+ MINI Forums
+ Porsche Forums
+ General Discussion
+ Marketplace Forums
Re: Same Thing... (archive)

[ Follow Ups ] [ E30 M3 Message Board ] [ Msg. Board FAQ ]

Posted by Dave on January 27, 2000 at 11:46:43:

In Reply to: Same Thing... posted by Joel on January 27, 2000 at 10:47:42:

: Same thing happened to me during our first cold spell in DC two weeks ago. I was blowing coolant out of my coolant overflow tube, that comes out of the coolant reservoir, right onto the exhaust manifold. My coolant light also came on and the engine ran warmer than usually, although the needle is still not even to the straight up tic mark, and it seemed to run ok.

: Haven't had it fixed yet, due to all of the snow here lately, but people have told me to look either for:

: 1. Thermostat stuck closed
: 2. The reservoir cap is not seated right (make sure you have the redesigned one).

: Please let me know what you find out, since my baby is under 13" of snow :-(

: -Joel Smernoff
: '96 Z3
: '88 M3

I'll let you know. Its not the overflow cause I pulled the hose and watched it and nothing was coming out of it. Its coming from somewhere well back of the engine compartment. Hoping its not the heater core.


Follow Ups:



[ Follow Ups ] [ E30 M3 Message Board ] [ Msg. Board FAQ ]
Questions, comments, or problems, please visit the Roadfly help desk.
Roadfly.com Logo © 1997 - 2016 Jump Internet Inc. All rights reserved.