The complete automotive resource for buyers, sellers, and owners like you.
Car, Truck and SUV Forums at Roadfly
+ Bentley Forums
+ BMW Forums
+ Cadillac Forums
+ Chevrolet Forums
+ Ferrari Forums
+ Jaguar Forums
+ Lamborghini Forums
+ Lotus Forums
+ Mercedes-Benz Forums
+ Maserati Forums
+ MINI Forums
+ Porsche Forums
+ General Discussion
+ Marketplace Forums
Re:read this one (archive)

[ Follow Ups ] [ E30 M3 Message Board ] [ Msg. Board FAQ ]

Posted by John on June 06, 2000 at 01:56:22:

In Reply to: Re:read this one posted by Troy on June 05, 2000 at 12:34:37:

: : I have a 87/D M3 E30 with about 140,000 miles on the clock. Been running like a dream for 2 years but recently on startup the engine sounds like a diesel for about 30 secs then runs OK. Thought it might be a timing chain problem but doesn't always happen.
: : Car is regularly serviced and OIL level is fine.
: : Any idea's.

: Hello, I was having the same problem with my car ,I found my oil seals around my timing chain tensioner were leaking. I replaced them and the problem went away. I still have alot of timing chain noise while the car is running but that is because the chain is stretched. I am going to replace it next week. You could have a worn plunger and spring in your tensioner, a week oil pump and or stretched timing chain. Check your oil pressure output first, then your tensioner.
: The tensioner is the cheapest fix and the easiest. due to the milage on your car you might as well replace the timing chain at the same time.
: It can be done from the top of the engine rather then removing the front cover's. But you must first figure out which master link you need to get from your local Mercedes dealership. Because BMW does not stock one.
: Good luck,
: Troy

Many Thanks, I will get it checked.


Follow Ups:



[ Follow Ups ] [ E30 M3 Message Board ] [ Msg. Board FAQ ]
Questions, comments, or problems, please visit the Roadfly help desk.
Roadfly.com Logo © 1997 - 2016 Jump Internet Inc. All rights reserved.