The complete automotive resource for buyers, sellers, and owners like you.
Car, Truck and SUV Forums at Roadfly
+ Bentley Forums
+ BMW Forums
+ Cadillac Forums
+ Chevrolet Forums
+ Ferrari Forums
+ Jaguar Forums
+ Lamborghini Forums
+ Lotus Forums
+ Mercedes-Benz Forums
+ Maserati Forums
+ MINI Forums
+ Porsche Forums
+ General Discussion
+ Marketplace Forums
Cooloing System Inquiry (archive)

[ Follow Ups ] [ E30 M3 Message Board ] [ Msg. Board FAQ ]

Posted by jej on December 08, 2001 at 16:40:34:

My '88 M3 has a rather strange cooloing system problem. I warm weather (60 F), I usually run the AC fan to keep the engine cool, i.e. I have a leakin the refrigerant system, such that the fan will turn on, but the compressor does not engage. My temperature guage will stay just below the mid point.

In cold weather (30 F), it is hard to get much heat and the temperature guage doesn't register at all or stays in the blue area. This is with the AC fan turned off. The engine fan seems to always be working.

Recently, in cold weather, coolant is being discharged through the reservour overflow tube that runs into the right side frame. I have replaced the reservour cap, but the problem persists to the point that the coolant warning light comes on, most likely the sensor indicating the coolant level in the reservour.

Before replacing the thermostat, I would appreciate any other recommendations or testing procedures. Thanks in advance, jon


Follow Ups:



[ Follow Ups ] [ E30 M3 Message Board ] [ Msg. Board FAQ ]
Questions, comments, or problems, please visit the Roadfly help desk.
Roadfly.com Logo © 1997 - 2017 Jump Internet Inc. All rights reserved.