The complete automotive resource for buyers, sellers, and owners like you.
Car, Truck and SUV Forums at Roadfly
+ Bentley Forums
+ BMW Forums
+ Cadillac Forums
+ Chevrolet Forums
+ Ferrari Forums
+ Jaguar Forums
+ Lamborghini Forums
+ Lotus Forums
+ Mercedes-Benz Forums
+ Maserati Forums
+ MINI Forums
+ Porsche Forums
+ General Discussion
+ Marketplace Forums
Battery Light/Idle High (archive)

[ Follow Ups ] [ E30 M3 Message Board ] [ Msg. Board FAQ ]

Posted by Ryan on January 23, 2002 at 12:07:58:

Hi everyone! Haven't posted here for a long time. I still have a couple of problems with my '89 M3 (imagine that).
First things first. I just recently had my alternator rebuilt because the diodes were fried. After installing it, my battery light goes on only when the car is off. When I turn on the ignition, the light goes off. I can't really tell if this was a problem before, as when the alternator went dead, the three lights went on including the battery light. Any thoughts as to what might be causing this problem??

Also my idle sits at about 1100 rpms. It has done this since I have owned the car. I replaced the intake manifold gaskets last summer, and I don't think I have a vacuum problem (engine idles smooth). Any thoughts?

Thanks for all your assistance.
Ryan (no longer in SoCal, stuck in rural Oregon for now)

Follow Ups:

[ Follow Ups ] [ E30 M3 Message Board ] [ Msg. Board FAQ ]
Questions, comments, or problems, please visit the Roadfly help desk. Logo © 1997 - 2016 Jump Internet Inc. All rights reserved.