The complete automotive resource for buyers, sellers, and owners like you.
Car, Truck and SUV Forums at Roadfly
+ Bentley Forums
+ BMW Forums
+ Cadillac Forums
+ Chevrolet Forums
+ Ferrari Forums
+ Jaguar Forums
+ Lamborghini Forums
+ Lotus Forums
+ Mercedes-Benz Forums
+ Maserati Forums
+ MINI Forums
+ Porsche Forums
+ General Discussion
+ Marketplace Forums
Yikes, mine too! (archive)

[ Follow Ups ] [ E30 M3 Message Board ] [ Msg. Board FAQ ]

Posted by Jon on March 22, 2002 at 16:02:41:

In Reply to: Broken Engine Mount -> Subframe Reinforcement posted by george on March 21, 2002 at 15:11:43:

I just looked at my R/S engine mount and I've got a small crack right in line with yours where it goes past the lower rear bolt hole.

I just ordered an new one...$34.86...not too bad for an M3-specific part.

Thanks!

-Jon



Thank God this didn't happen on a track! :)

Symptoms:

Inital:
Strange Feel in the Chassis.
Strange Feel in Steering.

After a few minutes:
Feelings stronger.
Engine Fan contacting shroud.

Diagnosis:
Right Engine Mount (not the rubber-liquid mount) failure. As you can see in the photo, it a was quite extensive falure. :)

Treatment:
Replace Mount.

Thought Process:
Oh crap. Thats bad. Engine Resting on Steering Rack... Time to remove the front end. Hmm I could do this too... and this... and this... ...

Net result:
New Engine Mount, New Rubber engine mounts, new (to me) reinforced (by me) subframe (ooh! its so pretty! :D), new control arms, new control arm bushings.

Thoughts on the mount breaking? Anyone seen this before?

-george





Follow Ups:



[ Follow Ups ] [ E30 M3 Message Board ] [ Msg. Board FAQ ]
Questions, comments, or problems, please visit the Roadfly help desk.
Roadfly.com Logo © 1997 - 2017 Jump Internet Inc. All rights reserved.