The complete automotive resource for buyers, sellers, and owners like you.
Car, Truck and SUV Forums at Roadfly
+ Bentley Forums
+ BMW Forums
+ Cadillac Forums
+ Chevrolet Forums
+ Ferrari Forums
+ Jaguar Forums
+ Lamborghini Forums
+ Lotus Forums
+ Mercedes-Benz Forums
+ Maserati Forums
+ MINI Forums
+ Porsche Forums
+ General Discussion
+ Marketplace Forums
Fuel pump malfunction? (archive)

[ Follow Ups ] [ 7-series (E32) Message Board ] [ Msg. Board FAQ ]

Posted by A. Trojanowski on January 06, 2001 at 11:56:45:

My 93 740i 120k. started "ailing" recently again.
After 100 miles (plus/minus) highway (I.95) driving in cold weather (Maine winter) irregular firing and loss of power slows the car to below 60 m./hour, check engine light comes on. After a minute or two the problem dissapears and in the next few minutes check engine light goes off. This repeats itself again and again on the same long distance trips. Electronic testing indicates both oxygen sensors failure. My trusted mechanic's interpretation is that it is probably failure of gas supply (lean mixture) rather than O2 sensors failure. (No engine codes detected, idling is precise like the Swiss watch). We've replaced fuel filters which unfortunatelly did not cure the problem and ordered an expensive fuel pump.
Question: Is it possible for the fuel pump to play-up like that, or do they just pack-up completely when they malfunction?
I would appreciate comments before I install a new pump.

Andrzej Trojanowski


Follow Ups:



[ Follow Ups ] [ 7-series (E32) Message Board ] [ Msg. Board FAQ ]
Questions, comments, or problems, please visit the Roadfly help desk.
Roadfly.com Logo © 1997 - 2017 Jump Internet Inc. All rights reserved.