The complete automotive resource for buyers, sellers, and owners like you.
Car, Truck and SUV Forums at Roadfly
+ Bentley Forums
+ BMW Forums
+ Cadillac Forums
+ Chevrolet Forums
+ Ferrari Forums
+ Jaguar Forums
+ Lamborghini Forums
+ Lotus Forums
+ Mercedes-Benz Forums
+ Maserati Forums
+ MINI Forums
+ Porsche Forums
+ General Discussion
+ Marketplace Forums
Re: Speedo whacky (archive)

[ Follow Ups ] [ 7-series (E32) Message Board ] [ Msg. Board FAQ ]

Posted by gale on April 02, 2001 at 23:39:28:

In Reply to: Speedo whacky posted by Jordan Ward on April 02, 2001 at 17:54:12:

It could be the speed sensor which is located the differential, Bentley's covers how to get at it. It's a bit of a bugger to get to but you should be able to see it above the diff. May be as simple as uplugging & cleaning the socket & terminals & putting a little antioxidant grease on it, just came from Portland & I know all too well how wet weather can play havoc on electrical connections. Also, about 10 posts above yours, the classic "capacitor fix" solved a multitude of instrument cluster glitches, check Bruno's excellent e34 tech write-up on this:

http://www.bmwe34.net/E34main/Maintenance/Electrical/Capacitors.htm


I just took a roadtrip to seattle and back last weekend (from portland) and on the way there the speedometer would float around my actual speed by about 5mph in both directions...
On the way home, it would jump from 20mph to 80mph every few seconds... Is this a sensor problem? I noticed it was effecting the obc readings aswell (inaccurate speed messed up the mpg, etc) is this a sensor on the rear tires somewhere for the odometer/speedometer?

Thanks,
Jordan Ward
'88 735i, 187,000





Follow Ups:



[ Follow Ups ] [ 7-series (E32) Message Board ] [ Msg. Board FAQ ]
Questions, comments, or problems, please visit the Roadfly help desk.
Roadfly.com Logo © 1997 - 2017 Jump Internet Inc. All rights reserved.