The complete automotive resource for buyers, sellers, and owners like you.
Car, Truck and SUV Forums at Roadfly
+ Bentley Forums
+ BMW Forums
+ Cadillac Forums
+ Chevrolet Forums
+ Ferrari Forums
+ Jaguar Forums
+ Lamborghini Forums
+ Lotus Forums
+ Mercedes-Benz Forums
+ Maserati Forums
+ MINI Forums
+ Porsche Forums
+ General Discussion
+ Marketplace Forums
Lambda Emissions fault. Your opinions requested! (archive)

[ Follow Ups ] [ 7-series (E32) Message Board ] [ Msg. Board FAQ ]

Posted by Paul on August 09, 2001 at 23:29:36:

1990 750iL 170,000 mi.
Symptoms before: Lots of blue smoke on startup, and when tromping on it. Lugged below 2500rpm, then gobs of power as tach jumped from 2500 to 3100. Just did valve job, head gasket, and injector recalibration, 10 of 12 failed.
Symptoms now: rich fuel smell, good smooth accelleration w/ just a hint of smoke. Check Engine fault pinpointed by Peak research tool is 0A-Emission (lambda) control. Ck Eng light goes out after rpm above 2300. When 'coasting', light remains out until lightly adding power (fuel).
Add'l info: cyl's all looked good, no ring ridges, but lots of carbon (I'd suspect from the valve seals/guides). LH AFM recently replaced just before I bought the car last month.
Could this be an O2 sensor, or a fuel reg, too high fuel pressure?
What should I go for next?



Follow Ups:



[ Follow Ups ] [ 7-series (E32) Message Board ] [ Msg. Board FAQ ]
Questions, comments, or problems, please visit the Roadfly help desk.
Roadfly.com Logo © 1997 - 2017 Jump Internet Inc. All rights reserved.