The complete automotive resource for buyers, sellers, and owners like you.
Car, Truck and SUV Forums at Roadfly
+ Bentley Forums
+ BMW Forums
+ Cadillac Forums
+ Chevrolet Forums
+ Ferrari Forums
+ Jaguar Forums
+ Lamborghini Forums
+ Lotus Forums
+ Mercedes-Benz Forums
+ Maserati Forums
+ MINI Forums
+ Porsche Forums
+ General Discussion
+ Marketplace Forums
Re: How many miles? I have something very similiar (archive)

[ Follow Ups ] [ 7-series (E32) Message Board ] [ Msg. Board FAQ ]

Posted by Keith '88 750il on August 12, 2001 at 07:14:39:

In Reply to: How many miles? I have something very similiar!! posted by tom on August 11, 2001 at 23:50:20:

Mine is an '88 750il with 130,000 miles. I don't get the Check Engine light, but have wondered why I don't. I suspect, that it may not work. At times it idles very rough and has absolutely no power until you mash the peddle. Mine has not backfired, but as rich as the exhaust gets, its amazing that it hasn't.

I've already changed one coil (it was bad), one set of plug wires (one was bad the other gave me good resistance readings), both distributor caps and rotors, and replaced the bonnets going to the MAF. As I said, a mechanic replaced the 02 sensors. To my amazement, the engine still runs the same. Each of the things was bad, yet replacing them seems to have made no difference. It only runs bad after being on the road for about 10 minutes, and sometimes can clear itself up for short periods of time, after mashing the peddle to the floor.


and have taken care of the trail of smoke and rich gasoline smell in the exhaust. Mine backfires sometimes at start off (1 out of 5 or so..), and I've still got the same 'dead spot' then rush of power you speak of, but I get a check engine light when I'm mashing the pedal.

I also get a check engine light 2 minutes after start up, but I can make it go away by increasing rpms to 2400 for about 10 seconds. On the road, as long as I'm above 2400, theres no ck eng light. When 'coasting', the light comes on again just as i begin to add power in the 'dead' spot. Peak Research Tool says Lambda Emission Control.
Just ground the valves and re-calibrated the injectors (10 of 12 failed), and this is the only problem I have left. Maybe someone has a fix for the same symptoms??
'90 750iL 170,000 mi





Follow Ups:



[ Follow Ups ] [ 7-series (E32) Message Board ] [ Msg. Board FAQ ]
Questions, comments, or problems, please visit the Roadfly help desk.
Roadfly.com Logo © 1997 - 2017 Jump Internet Inc. All rights reserved.