The complete automotive resource for buyers, sellers, and owners like you.
Car, Truck and SUV Forums at Roadfly
+ Bentley Forums
+ BMW Forums
+ Cadillac Forums
+ Chevrolet Forums
+ Ferrari Forums
+ Jaguar Forums
+ Lamborghini Forums
+ Lotus Forums
+ Mercedes-Benz Forums
+ Maserati Forums
+ MINI Forums
+ Porsche Forums
+ General Discussion
+ Marketplace Forums
Old, New 750iL (long) (archive)

[ Follow Ups ] [ 7-series (E32) Message Board ] [ Msg. Board FAQ ]

Posted by Tracy Evans on August 12, 2001 at 11:53:15:


So a month ago I bought a 1989 750iL with only 18,000 miles on it. It was one owner, miles are documented.. it sat a lot. I got a good deal on it and it's a gorgeous car. I've put about 1500 miles on it since and am just begining to understand my new toy..

The car runs well, it's fast and comfortable, but it has a few issues. Here they are:

Seems like everything works, exept for the power headrest on the drivers side in the back seat.

I get a message of "POW STEER FLUID" on the computer about half the time I start (or shutdown for that matter). Fluid is not low, found a bad sensor on the hydraulic regulator (it was leaking), replaced it and bled the system according to my bently book. I've noticed the two serpentine belts are cracked and losing chunks, goes in tomorrow to have them replaced, but I'm leary of this fixing my problem. I'll not that the steering doesn't really feel quite right when cold and at low speeds, but it's hard to describe, feels fine at speed.

Had "Trans Program Error" on hot days, them my SEM switch didn't work. This was always temporary. I think I've nailed this one, buy unplugging and reseating all the relays and connectors I could find. There was some minor oxidation on the contacts. But the problem has not returned and I've had a lot of hot days since then.

Backing off the gas during high speed (70-80mph) jaunts will cause the check engine light to flicker.

Driving at night with the lights on, I periodically get a message about a Parking Light Failure, though I don't find any lights out. I've reseated the LKM to no avail. I did, once, find my left rear tail light out, but tapping on it brought it back. I've reseated all the bulbs and connectors associated with it that I can find in the trunk.

When I start the car in the morning, and it always starts right up, for about 30 seconds, the temp and gas gauges show nothing and the computer display is blank. Then it 'pops' and everything works.. At least as far as I can tell.. Some times I notice flickering on the LED display. This only occurs in the morning, no other time during the day.

So there's my list.. I consider the power steering the issue needing to be addressed first. My plan is after the belts, if the problem is still there, as I suspect it will be, is to replace the all the fluid (pentozin chf 7.1, this car has the LAD system). Maybe look at that switch in the resevoir. Though I don't reacall seeing that in my Bently. I should note that if I just turn the car on, but not start the engine, I will still get the low fluid message, but I cannot find any fault codes in the computer using the 'stomp on the gas 5 times in 5 seconds' method mention in Bently. (any recommendations on a decent fault code reader, Peake?).. Maybe test the pump pressure, but I'm looking for ideas..

As for the Transmission and Parking lights issue, I'm thinking a fluid and filter change is probably in order for the transmission. And I think I need to break out my soldering iron and touch up joints in the LKM (or whatever it's called).

Check engine light flicker is probably an O2 sensor complaining.

And the odd dash activity may be more soldering..

So I'm looking for comments. Anyone have any ideas on any of the areas I'm diving into, please let me know if you think I'm doing the right things or if I'm missing something. This will be greatly appreciated...

Thanks,

Tracy


Follow Ups:



[ Follow Ups ] [ 7-series (E32) Message Board ] [ Msg. Board FAQ ]
Questions, comments, or problems, please visit the Roadfly help desk.
Roadfly.com Logo © 1997 - 2017 Jump Internet Inc. All rights reserved.