The complete automotive resource for buyers, sellers, and owners like you.
Car, Truck and SUV Forums at Roadfly
+ Bentley Forums
+ BMW Forums
+ Cadillac Forums
+ Chevrolet Forums
+ Ferrari Forums
+ Jaguar Forums
+ Lamborghini Forums
+ Lotus Forums
+ Mercedes-Benz Forums
+ Maserati Forums
+ MINI Forums
+ Porsche Forums
+ General Discussion
+ Marketplace Forums
Re: Horn still is not working... (archive)

[ Follow Ups ] [ 7-series (E32) Message Board ] [ Msg. Board FAQ ]

Posted by Bimmer lover '88 735I on October 11, 2001 at 01:02:55:

In Reply to: Horn still is not working... posted by Jake 88 750iL on October 10, 2001 at 22:22:59:

use your meter and check if power is going to the horn you might have bad horns i just change mine last week.

The horns on my car are not working- I thought that maybe I knocked something loose when I installed a new radio this summer, but I took off the lower panel on the drivers side and everything looks all right. I switched the horn relay in the front power distribution box with another one like it (same part #) and still no horn. The fuse is fine. Does anyone have any suggestions? Is there a common failure? I do not know when the horn stopped working, just that it used to work fine.
I have a multi meter- how do I check that the horn relay is getting power, or that the switch is making contact? Any help is appreciated. TIA.





Follow Ups:



[ Follow Ups ] [ 7-series (E32) Message Board ] [ Msg. Board FAQ ]
Questions, comments, or problems, please visit the Roadfly help desk.
Roadfly.com Logo © 1997 - 2017 Jump Internet Inc. All rights reserved.