The complete automotive resource for buyers, sellers, and owners like you.
Car, Truck and SUV Forums at Roadfly
+ Bentley Forums
+ BMW Forums
+ Cadillac Forums
+ Chevrolet Forums
+ Ferrari Forums
+ Jaguar Forums
+ Lamborghini Forums
+ Lotus Forums
+ Mercedes-Benz Forums
+ Maserati Forums
+ MINI Forums
+ Porsche Forums
+ General Discussion
+ Marketplace Forums
Re: Jim Conforti 530i chip question (archive)

[ Follow Ups ] [ 5-series (E34) Message Board ] [ Msg. Board FAQ ]

Posted by ron on March 30, 1999 at 08:07:51:

In Reply to: Jim Conforti 530i chip question posted by Steve on March 29, 1999 at 19:46:47:

: I just installed a Jim C chip on my '95 530i / 5 speed/ has air pump to intake box. When I come to a stop the rpm's drop to 500 causing a slight surge in rpm's. Also, when just crawling in 1st or even 2nd the car has tendency o buck much more than with the original chip. Any clue what's wrong or is this normal. Otherwise it is much smoother, and more respnsive especially between 2300 - 3500 rpm's
: Also couldn't get orignal computer holding(what a bitch)clips back in, I temporarily wedged two small pieces of paint stick until I can get help.
: Thanx in advance for any help or advice

Steve, RIGHT after i sharked my 525i, it was a little rough on launch like you mention, but it smoothed out after about 40-50 miles. The computer needs to "relearn," similar to when you disconnect the battery for an ext. period. Also, it's important to have a full tank of premium BEFORE installing the chip. If it doesn't smooth out, give them a call, you might have a buggy chip...it happens.


Follow Ups:



[ Follow Ups ] [ 5-series (E34) Message Board ] [ Msg. Board FAQ ]
Questions, comments, or problems, please visit the Roadfly help desk.
Roadfly.com Logo © 1997 - 2017 Jump Internet Inc. All rights reserved.