The complete automotive resource for buyers, sellers, and owners like you.
Car, Truck and SUV Forums at Roadfly
+ Bentley Forums
+ BMW Forums
+ Cadillac Forums
+ Chevrolet Forums
+ Ferrari Forums
+ Jaguar Forums
+ Lamborghini Forums
+ Lotus Forums
+ Mercedes-Benz Forums
+ Maserati Forums
+ MINI Forums
+ Porsche Forums
+ General Discussion
+ Marketplace Forums
Re: 89 535i SI Malfunction (archive)

[ Follow Ups ] [ 5-series (E34) Message Board ] [ Msg. Board FAQ ]

Posted by manacher on March 30, 1999 at 15:39:36:

In Reply to: Re: 89 535i SI Malfunction posted by There are no batteries in on March 29, 1999 at 12:52:49:

There is a circuit board behind the cluster on the bottom.two LITHIUM batteries next to each other they get charged with car normal charging system .they are connected to their post with special soldering ,which make it impossible to instal new batteries in(if be able to find them ) YOU could buy the bord after market or from dealer . You should pay attention to the arrow on new bord before insttaling it on cluster.Good luck. Manacher. anot : : My '89 535i which sat in the garage with the engine/trans out all winter is now giving false messages on the SI readout. The messages which began about two weeks after I reassembled the car are for brake linings, oil level, and oil pressure sensor. I'm pretty sure that all three of these sensors could not have gone faulty in one week and I know for a fact that the brake lining sensors are intact. I've heard that in some BMW's there are batteries that can die in the instrument cluster. Can someone confirm this for this specific model? I have removed and dissassembled the instrument cluster but have not been able to locate any batteries. Any help will be sincerely appreciated.





Follow Ups:



[ Follow Ups ] [ 5-series (E34) Message Board ] [ Msg. Board FAQ ]
Questions, comments, or problems, please visit the Roadfly help desk.
Roadfly.com Logo © 1997 - 2017 Jump Internet Inc. All rights reserved.