The complete automotive resource for buyers, sellers, and owners like you.
Car, Truck and SUV Forums at Roadfly
+ Bentley Forums
+ BMW Forums
+ Cadillac Forums
+ Chevrolet Forums
+ Ferrari Forums
+ Jaguar Forums
+ Lamborghini Forums
+ Lotus Forums
+ Mercedes-Benz Forums
+ Maserati Forums
+ MINI Forums
+ Porsche Forums
+ General Discussion
+ Marketplace Forums
Re: 518i hard to start when cold (archive)

[ Follow Ups ] [ 5-series (E34) Message Board ] [ Msg. Board FAQ ]

Posted by John G.Burns on April 01, 1999 at 05:27:22:

In Reply to: 518i hard to start when cold posted by ken on March 31, 1999 at 22:49:02:

: My car is a 518i manual E34 1991 M40/B18 engine.

: I have to turn the key for a long time and accelerate to start the engine. When it is running the engine vibrates and when I accelerate it returns to normal.
: Someone told me it was cold starting valve or is it the injectors which are leaking. The engine makes clicking sound when accelerating or driving uphill.

: Does this car has a cold starting valve or is it another thing is not working well?

I'd bet your coolant temperature sensor has passed away. Not sure if the M40 also has a thermo time switch as it could be that too. On the M20 they were wired in series so either one could cause your problem.


Follow Ups:



[ Follow Ups ] [ 5-series (E34) Message Board ] [ Msg. Board FAQ ]
Questions, comments, or problems, please visit the Roadfly help desk.
Roadfly.com Logo © 1997 - 2017 Jump Internet Inc. All rights reserved.