The complete automotive resource for buyers, sellers, and owners like you.
Car, Truck and SUV Forums at Roadfly
+ Bentley Forums
+ BMW Forums
+ Cadillac Forums
+ Chevrolet Forums
+ Ferrari Forums
+ Jaguar Forums
+ Lamborghini Forums
+ Lotus Forums
+ Mercedes-Benz Forums
+ Maserati Forums
+ MINI Forums
+ Porsche Forums
+ General Discussion
+ Marketplace Forums
blower resistor (archive)

[ Follow Ups ] [ 5-series (E34) Message Board ] [ Msg. Board FAQ ]

Posted by Michel Mitias on April 01, 1999 at 20:52:16:

I have seen several posts relating to the problem that I currently have with my blower unit. It does not work on speeds 1,2, and 3. It works fine on 4, but this makes me feel like I am in a wind tunnel. Anyway, the dealer told me it was most likely the resistor and it needed to be replaced. Well, I bought the resistor and followed the directions in the Bentley manual like I usually do. I could not seem to find it anywhere. The picture in the manual is pretty clear as to where it is, but I cannot find it in the same location.
I know BMW used different blower systems and it specified my unit is a IHKRIII which corresponds to a 1993 525i. This system is supposed to use the little blue resistor that I bought from the dealer for around $14.50.
Does anybody have any suggestions as to where the resistor might be or if the manual is incorrect and mine uses a different system than the one Bentley indicates. The dealer (parts guy) looked it up on his BMW database and the picture showed the resistor where the blower unit is (underneath hood). The manual indicates the resistor is along the left side of the console.

I will be very appreciative if somebody has encountered this problem and figured it out.


Thanks,

Michel


Follow Ups:



[ Follow Ups ] [ 5-series (E34) Message Board ] [ Msg. Board FAQ ]
Questions, comments, or problems, please visit the Roadfly help desk.
Roadfly.com Logo © 1997 - 2017 Jump Internet Inc. All rights reserved.