The complete automotive resource for buyers, sellers, and owners like you.
Car, Truck and SUV Forums at Roadfly
+ Bentley Forums
+ BMW Forums
+ Cadillac Forums
+ Chevrolet Forums
+ Ferrari Forums
+ Jaguar Forums
+ Lamborghini Forums
+ Lotus Forums
+ Mercedes-Benz Forums
+ Maserati Forums
+ MINI Forums
+ Porsche Forums
+ General Discussion
+ Marketplace Forums
A/C problems and Aux Fan and Temp problems (archive)

[ Follow Ups ] [ 5-series (E34) Message Board ] [ Msg. Board FAQ ]

Posted by Mike on June 29, 1999 at 12:55:32:

Well, my air was busted about two weeks ago, all freon leaked out and I had a squeeling noise from the belt slipping. I took it in, they put in a new drier and filled it with freon. Air works good but still the squelling noise. Took it back, the guy says the Auxilary fan is not working, he tested it, and the fan has 2 speeds, it works on high but not on low, and the low speed is supposed to go on with the a/c. He says is just needs a new resistor, but he has to take the bumper off to get to it. IN talking to him, I asked him about the temperature gauge, he says it should NEVER go past the center mark or else there is a problem. He said even with the a/c on and the 100 degrees outside. Hopefully with the aux fan working, he will be right. IF not I may need a new thermostat. So for all those with car running hot, make sure your auxilary fan works on both the high and low settings. This is an independent shop, work on mercedes/bmw/volvo. He owns a 535 so knows the car well. Oh, about the squeeling, he said that the pressure builds up in the compressor, and without the fan to release the pressure, the belt slips, hopefully he is right, will find out later today.


Follow Ups:



[ Follow Ups ] [ 5-series (E34) Message Board ] [ Msg. Board FAQ ]
Questions, comments, or problems, please visit the Roadfly help desk.
Roadfly.com Logo © 1997 - 2017 Jump Internet Inc. All rights reserved.