The complete automotive resource for buyers, sellers, and owners like you.
Car, Truck and SUV Forums at Roadfly
+ Bentley Forums
+ BMW Forums
+ Cadillac Forums
+ Chevrolet Forums
+ Ferrari Forums
+ Jaguar Forums
+ Lamborghini Forums
+ Lotus Forums
+ Mercedes-Benz Forums
+ Maserati Forums
+ MINI Forums
+ Porsche Forums
+ General Discussion
+ Marketplace Forums
Re: 90 525i Rough Idle - O2 sensor? (archive)

[ Follow Ups ] [ 5-series (E34) Message Board ] [ Msg. Board FAQ ]

Posted by RM on July 08, 1999 at 12:38:10:

In Reply to: 90 525i Rough Idle - O2 sensor? posted by Dave on July 03, 1999 at 06:35:35:

: Hi
: I have a '90 525i and love it! The car has a very rough idle. I have read a bit on the O2 sensor, and was wondering if it could be causing the problem with the idle. Pretty sure it just idles on 5. No signs of a blown head gasket, cracked block or anything like that.
: Any suggestions appreciated.
: Also - Is it hard to change the thermostat on a E34 M20 2.5 Where can I get some instructions from?
: Dave

: BTW: #2 plug is always dirty with soot whenever I check them also. Related?

I've got an '89 525i....they should run very smooth! BAd O2 sensor usually shows up as poor mpg...not much else. Sounds like dirty injectors. Try running a few tanks with concentrated Techron inj cleaner (full tank w /two bottles or 1/2 tank w/one bottle) and see if the idle improves. Another item to check is the idle control valve (ICV). This Bosch valve keeps the idle constant and they ususlly go by 90K miles. Good luck, i think you will see improvement after running a few tanks, and don't be afraid to run highway (opens and cleans the injectors better...and it's fun!)


Follow Ups:



[ Follow Ups ] [ 5-series (E34) Message Board ] [ Msg. Board FAQ ]
Questions, comments, or problems, please visit the Roadfly help desk.
Roadfly.com Logo © 1997 - 2017 Jump Internet Inc. All rights reserved.