The complete automotive resource for buyers, sellers, and owners like you.
Car, Truck and SUV Forums at Roadfly
+ Bentley Forums
+ BMW Forums
+ Cadillac Forums
+ Chevrolet Forums
+ Ferrari Forums
+ Jaguar Forums
+ Lamborghini Forums
+ Lotus Forums
+ Mercedes-Benz Forums
+ Maserati Forums
+ MINI Forums
+ Porsche Forums
+ General Discussion
+ Marketplace Forums
Re: Coupe´ fan doesn´t work (archive)

[ Follow Ups ] [ 5-series (E34) Message Board ] [ Msg. Board FAQ ]

Posted by Ben on September 14, 1999 at 23:33:44:

In Reply to: Coupe´ fan doesn´t work posted by Hasse from Sweden on September 14, 1999 at 14:41:11:

Are you talking about the fan that blows air through your cabin vents? (4 position knob beneath radio). Or are you talking about your auxiliary fan (in front of the radiator?)

Case #1: Depending on the year of your car, your fan resistor or "sword" may be failing. This prevents the first 3 speeds on your fan from operating, but it will allow MAX speed (or position 4 on the knob). The resistor pack is cheap, the sword is expensive but can be repaired.

Case #2: If your auxiliary fan is only working at one speed, it might be a the fan resistor (in-line with fan circuit).

In either case, search the archives as these are common problems.

Good luck,
Ben
90 535iM, sharked, CCA


Follow Ups:



[ Follow Ups ] [ 5-series (E34) Message Board ] [ Msg. Board FAQ ]
Questions, comments, or problems, please visit the Roadfly help desk.
Roadfly.com Logo © 1997 - 2017 Jump Internet Inc. All rights reserved.