The complete automotive resource for buyers, sellers, and owners like you.
Car, Truck and SUV Forums at Roadfly
+ Bentley Forums
+ BMW Forums
+ Cadillac Forums
+ Chevrolet Forums
+ Ferrari Forums
+ Jaguar Forums
+ Lamborghini Forums
+ Lotus Forums
+ Mercedes-Benz Forums
+ Maserati Forums
+ MINI Forums
+ Porsche Forums
+ General Discussion
+ Marketplace Forums
Re: 89 525i Blinking DIMS / speedo won't speedo, s (archive)

[ Follow Ups ] [ 5-series (E34) Message Board ] [ Msg. Board FAQ ]

Posted by Michael Holland on November 04, 1999 at 11:15:33:

In Reply to: 89 525i Blinking DIMS / speedo won't speedo, still posted by Michael Holland on November 03, 1999 at 10:32:48:

: Thank you all who advised. I am still experiencing problems.

: My car is a 1989 5251 with 155,000 pampered miles.

: I purchased a new LCM (Global Imports, Atlanta 278.00) and installed. I did this becuase one of the relays was actually bad. Problem is : it still blinks off (dims) randomly. Is it possible a new LCM has bad ground connections? I have checked the various grounds and power drop, everything seems ok. I am reluctant to re-solder the commections on a new unit. I can "rap" the top of the box and the lights will come back on sometimes for a short while sometimes for the duration of my trip. I hate to take this to the dealer, it's probably a simple fix. I will check with the dealer to exchange the unit if they will not I will re-solder.

: The other problem is still the speedometer. It takes between 3 and 7 miles for it to start working in the morning (almost like it has to warm up). sometimes it tries to work and drops back to 0. I have checked the connectors and cleaned them externally. I have not cut the seal to actually remove the connecter, that is next.

: Surely someone out there has had this problem.

: Thanks in advance

: Michael Holland
: [email protected]
:

I exchanged the new LCM for another new LCM at the dealer. After 135 miles no problems. I agree it probably was soldering issues as I have repaired other electronics via re-soldering.

I hope this problem is fixed, although I still wonder what caused the original relay to melt down.

Michael Holland



Follow Ups:



[ Follow Ups ] [ 5-series (E34) Message Board ] [ Msg. Board FAQ ]
Questions, comments, or problems, please visit the Roadfly help desk.
Roadfly.com Logo © 1997 - 2017 Jump Internet Inc. All rights reserved.