The complete automotive resource for buyers, sellers, and owners like you.
Car, Truck and SUV Forums at Roadfly
+ Bentley Forums
+ BMW Forums
+ Cadillac Forums
+ Chevrolet Forums
+ Ferrari Forums
+ Jaguar Forums
+ Lamborghini Forums
+ Lotus Forums
+ Mercedes-Benz Forums
+ Maserati Forums
+ MINI Forums
+ Porsche Forums
+ General Discussion
+ Marketplace Forums
Re: Also check archives on fusible links (archive)

[ Follow Ups ] [ 5-series (E34) Message Board ] [ Msg. Board FAQ ]

Posted by 525 has it, not sure on 535. ron (e) on November 08, 1999 at 14:36:38:

In Reply to: '89 535iA Will not start, need advice! posted by Craig Wright on November 06, 1999 at 17:06:42:

: This afternoon, after washing the car, I went to start it and to my surprise, all that I got was the tell tale tick,tick,tick,tick,tick. My first thought was the battery had gone south without warning. Twenty minutes later it hesitated for a second and then started right up. I'm confused. Before today I had no warning of the battery possibily loosing the charge. Do I need a new battery(if so what should I buy)? Could there possibily be a fault in the ignition system? Is it possible that moisture got into the engine bay and affected some wires? Any advice would be welcome as I can make repairs tomorrow so that I can get to work on Monday.
: TIA
: Craig Wright
: 89 535iA w/ 60K miles
: Inspection II around the corner




Follow Ups:



[ Follow Ups ] [ 5-series (E34) Message Board ] [ Msg. Board FAQ ]
Questions, comments, or problems, please visit the Roadfly help desk.
Roadfly.com Logo © 1997 - 2017 Jump Internet Inc. All rights reserved.