The complete automotive resource for buyers, sellers, and owners like you.
Car, Truck and SUV Forums at Roadfly
+ Bentley Forums
+ BMW Forums
+ Cadillac Forums
+ Chevrolet Forums
+ Ferrari Forums
+ Jaguar Forums
+ Lamborghini Forums
+ Lotus Forums
+ Mercedes-Benz Forums
+ Maserati Forums
+ MINI Forums
+ Porsche Forums
+ General Discussion
+ Marketplace Forums
Re: Need help to determine radio problems- 1993 52 (archive)

[ Follow Ups ] [ 5-series (E34) Message Board ] [ Msg. Board FAQ ]

Posted by Ben Waite on January 08, 2000 at 01:06:14:

In Reply to: Need help to determine radio problems- 1993 525i posted by Robert D Nevins on January 07, 2000 at 21:05:17:

I've had similar luck with an aftermarket receiver. Bothersome to say the least. But with the factory head unit you shouldn't have heat problems. The amp and the head unit are completely seperate.

Does your radio cut out even when it's just the radio that's playing or does it do it only for a tape?

I doubt you have a heat problem, it's more likely a loose connection either behind the head unit (hopefully or more hopefully a lose fuse?).

I wish I could tell you were the amp is for sure. I know on my wagon its in the left rear quarter of the trunk area (near the cd changer?) It's behind a padded area (up against the body panel). The sedan should be a little easier to get at.

I wish I could be more helpful.

Ben Waite


Follow Ups:



[ Follow Ups ] [ 5-series (E34) Message Board ] [ Msg. Board FAQ ]
Questions, comments, or problems, please visit the Roadfly help desk.
Roadfly.com Logo © 1997 - 2017 Jump Internet Inc. All rights reserved.