The complete automotive resource for buyers, sellers, and owners like you.
Car, Truck and SUV Forums at Roadfly
+ Bentley Forums
+ BMW Forums
+ Cadillac Forums
+ Chevrolet Forums
+ Ferrari Forums
+ Jaguar Forums
+ Lamborghini Forums
+ Lotus Forums
+ Mercedes-Benz Forums
+ Maserati Forums
+ MINI Forums
+ Porsche Forums
+ General Discussion
+ Marketplace Forums
Re: Service Light Reset Failure! Help? (archive)

[ Follow Ups ] [ 5-series (E34) Message Board ] [ Msg. Board FAQ ]

Posted by John Dilzell on February 24, 2000 at 07:23:05:

In Reply to: Service Light Reset Failure! Help? posted by Joe Mazza on February 23, 2000 at 11:43:29:

: I have retrieved from the archives the reset procedure for my '90 535i. They say to:

: - Turn ignition "off"
: - Jump pins 7 and 19
: - Turn ignition to "run" (not "start")
: - Wait for service lights to go out (5 seconds or so for Oil reset; 10 or so for Inspection reset)
: - Turn ignition "off"
: - Remove jumper

: I tried this several times, and the lights refused to reset (they stay at their current setting, in my case with the last (amber) light and "Inspection" lighted).

: I've successfull reset my lights in the past using, I think, the same procedure. (I have to look it up every time so there's a chance that the last time I looked the procedure was different.)

: Any guesses why it fails? I've tried all the obvious things like making sure I had the right pins (7 & 19), and making sure the jumper connections were good, and leaving the ignition at "run" for quite a awhile.

: Help!

: TIA

: Joe Mazza
: '90 535i(m) 221K+ miles and still going strong...
: '89 325 (m) 135K+ miles and going strong too...


This procedure does not work on my '94 530 either. What I have to do is remove the jumper with the ignition still on and then it resets. Give this a try.


Follow Ups:



[ Follow Ups ] [ 5-series (E34) Message Board ] [ Msg. Board FAQ ]
Questions, comments, or problems, please visit the Roadfly help desk.
Roadfly.com Logo © 1997 - 2017 Jump Internet Inc. All rights reserved.