The complete automotive resource for buyers, sellers, and owners like you.
Car, Truck and SUV Forums at Roadfly
+ Bentley Forums
+ BMW Forums
+ Cadillac Forums
+ Chevrolet Forums
+ Ferrari Forums
+ Jaguar Forums
+ Lamborghini Forums
+ Lotus Forums
+ Mercedes-Benz Forums
+ Maserati Forums
+ MINI Forums
+ Porsche Forums
+ General Discussion
+ Marketplace Forums
Re: A/T on 535i (archive)

[ Follow Ups ] [ 5-series (E34) Message Board ] [ Msg. Board FAQ ]

Posted by Paul Gill on February 24, 2000 at 12:22:07:

In Reply to: Re: A/T on 535i posted by TJ on February 23, 2000 at 00:39:41:

My 89 535 had shifting problems until I changed the fluid. This fixed the problem for a few weeks. But it returned. I have changed the filter 3 times and half of the fluid 5 times in 5 months. This seems to have fixed the problem for now but time will tell. I was getting the burnt fluid smell in the begining.

I am wondering if the clutches can be replaced by the average home mechanic or should I just have the transmission rebuilt?

As a side note the MPG needle gauge pins at 40MPG when the transmission starts having problems on my car.

Paul

: : I have a 89 535i that is having problems shifting. After the car is warm and running for a while then it shift with no problems, it does not slip.

: Jorge,
: You need to be a bit more specific. But if it is OK when it is warm, you might just need to change the Transmission oil and filter. Check the colour and smell the oil. If it looks burn't your clutches are on there way.




Follow Ups:



[ Follow Ups ] [ 5-series (E34) Message Board ] [ Msg. Board FAQ ]
Questions, comments, or problems, please visit the Roadfly help desk.
Roadfly.com Logo © 1997 - 2017 Jump Internet Inc. All rights reserved.