The complete automotive resource for buyers, sellers, and owners like you.
Car, Truck and SUV Forums at Roadfly
+ Bentley Forums
+ BMW Forums
+ Cadillac Forums
+ Chevrolet Forums
+ Ferrari Forums
+ Jaguar Forums
+ Lamborghini Forums
+ Lotus Forums
+ Mercedes-Benz Forums
+ Maserati Forums
+ MINI Forums
+ Porsche Forums
+ General Discussion
+ Marketplace Forums
Re: I'm sure someone has fixed this problem!! (archive)

[ Follow Ups ] [ 5-series (E34) Message Board ] [ Msg. Board FAQ ]

Posted by GeorgeK on March 28, 2000 at 13:33:51:

In Reply to: Re: I'm sure someone has fixed this problem!! posted by Chris B on March 28, 2000 at 13:18:01:

I have a 1991 535i. On my car, everytime a seat function was wrong, be it the memory function, the seatbase's length (sport seats) or the heating, it always came down to a faulty switch. It makes sense, as these switches are in a perfect position to ingest everything you throw at them. You'd be surprised of all the types of food remains you can find when you take the seatbase apart.
that's my two cents' worth.
Regards, George
: On my car (1990 525i) there is a relay in the seat backs of both seats. When you take the cover off they are on the side, close to the top. After changing the drivers side relay my seat heaters still didnt work. However, I blow a fuse everytime I engage the seat heater. Still dont know what is wrong. Maybe a short

: Chris B




Follow Ups:



[ Follow Ups ] [ 5-series (E34) Message Board ] [ Msg. Board FAQ ]
Questions, comments, or problems, please visit the Roadfly help desk.
Roadfly.com Logo © 1997 - 2017 Jump Internet Inc. All rights reserved.