The complete automotive resource for buyers, sellers, and owners like you.
Car, Truck and SUV Forums at Roadfly
+ Bentley Forums
+ BMW Forums
+ Cadillac Forums
+ Chevrolet Forums
+ Ferrari Forums
+ Jaguar Forums
+ Lamborghini Forums
+ Lotus Forums
+ Mercedes-Benz Forums
+ Maserati Forums
+ MINI Forums
+ Porsche Forums
+ General Discussion
+ Marketplace Forums
Check Engine - Idle Problems (archive)

[ Follow Ups ] [ 5-series (E34) Message Board ] [ Msg. Board FAQ ]

Posted by DD on March 31, 2000 at 08:57:35:

Here's the problem... I just finished traveling about 150 miles and stopped to drop off some papers. When I pulled into the parking lot, the car was idling around 1400rpms. I turned the key, shut off the car and was gone for 3min. I came back to the car and attempted to start it. The car started, then died. I tried to start the car again, same result. So, I started the car with my foot on the gas, and it stayed running. However, the "check engine" light was illuminated. I drove off and came to a stop light. The car almost died, but I pushed on the accelerator to keep it running. This went on for a few minutes. If I gave it alot of gas, it would "choke" and almost die. After a few minutes, I came to the freeway and got the car up to 60mph (took a while) and then the check engine light went out and the car became responsive again.

Can someone please assist me in determining how to fix this problem? I thought it might be the Oxygen sensor. What do you think?

"cool blue"
1990 535i



Follow Ups:



[ Follow Ups ] [ 5-series (E34) Message Board ] [ Msg. Board FAQ ]
Questions, comments, or problems, please visit the Roadfly help desk.
Roadfly.com Logo © 1997 - 2017 Jump Internet Inc. All rights reserved.