The complete automotive resource for buyers, sellers, and owners like you.
Car, Truck and SUV Forums at Roadfly
+ Bentley Forums
+ BMW Forums
+ Cadillac Forums
+ Chevrolet Forums
+ Ferrari Forums
+ Jaguar Forums
+ Lamborghini Forums
+ Lotus Forums
+ Mercedes-Benz Forums
+ Maserati Forums
+ MINI Forums
+ Porsche Forums
+ General Discussion
+ Marketplace Forums
Re: Your thoughts?(long...) (archive)

[ Follow Ups ] [ 5-series (E34) Message Board ] [ Msg. Board FAQ ]

Posted by Gino on October 26, 2000 at 17:17:06:

In Reply to: Your thoughts?(long...) posted by Chris on October 26, 2000 at 13:13:13:

Chris,

I just corrected a 1222 error code on my 91 535i. My bimmer was starting ok when cold or hot but when it was warm it would crank for 10 to 12 seconds before sputtering to life or if I cranked it for 4 or 5 seconds and then tried to restart it would fire right up. My gas mileage had dropped and there was a lot of carbon on the rip of the exhaust so with 205K on the car I thought it was the 02 sensor. I replaced the 02 sensor (what fun) and the problem was still there. Then I started to recheck for vacuum leaks and I found one. The connector for the vacuum line under the intake air boot had a small crack. I replaced it and the problem is fixed. Check for vacuum leaks after the after the air flow sensor, air restrictions before the air flow sensor and any dirt on the throttle plate.

Good luck

Gino



Follow Ups:



[ Follow Ups ] [ 5-series (E34) Message Board ] [ Msg. Board FAQ ]
Questions, comments, or problems, please visit the Roadfly help desk.
Roadfly.com Logo © 1997 - 2017 Jump Internet Inc. All rights reserved.