The complete automotive resource for buyers, sellers, and owners like you.
Car, Truck and SUV Forums at Roadfly
+ Bentley Forums
+ BMW Forums
+ Cadillac Forums
+ Chevrolet Forums
+ Ferrari Forums
+ Jaguar Forums
+ Lamborghini Forums
+ Lotus Forums
+ Mercedes-Benz Forums
+ Maserati Forums
+ MINI Forums
+ Porsche Forums
+ General Discussion
+ Marketplace Forums
Re: Help guys! I'm getting it all at once!!! (archive)

[ Follow Ups ] [ 5-series (E34) Message Board ] [ Msg. Board FAQ ]

Posted by Gary M on October 27, 2000 at 14:17:21:

In Reply to: Help guys! I'm getting it all at once!!! posted by John Morrison on October 27, 2000 at 10:44:54:

Your starting problem sounds like a battery to me, i.e. dim interior lights. However, interior lights normally take very little current. A better check for the battery is turning on your headlights to see how bright they are.


My 89 535ia wouldn't run over in the driveway this morning, made a click but that was it! I immediately though solenoid or starter motor but the interior lights seemed dim as well....charging system?? (it wouldn't boost, so I'm thinking solenoid).

Of course I live 40kms from my service center, so $80 in towing bills later....also...my car developed a horrible shimmy this week, at high speeds it feels like the wheels are coming off, must be bad upper control arm bushings....I'm having a really bad week!





Follow Ups:



[ Follow Ups ] [ 5-series (E34) Message Board ] [ Msg. Board FAQ ]
Questions, comments, or problems, please visit the Roadfly help desk.
Roadfly.com Logo © 1997 - 2017 Jump Internet Inc. All rights reserved.