The complete automotive resource for buyers, sellers, and owners like you.
Car, Truck and SUV Forums at Roadfly
+ Bentley Forums
+ BMW Forums
+ Cadillac Forums
+ Chevrolet Forums
+ Ferrari Forums
+ Jaguar Forums
+ Lamborghini Forums
+ Lotus Forums
+ Mercedes-Benz Forums
+ Maserati Forums
+ MINI Forums
+ Porsche Forums
+ General Discussion
+ Marketplace Forums
Re: I am interested... (archive)

[ Follow Ups ] [ 5-series (E34) Message Board ] [ Msg. Board FAQ ]

Posted by Richard V on November 20, 2000 at 22:33:48:

In Reply to: I am interested... posted by Chris B on November 20, 2000 at 21:59:00:

Chris, I can't answer your question concerning the fuse issue. On mine, the switch would light up but only the back would heat. I checked the checked the out put at the connector under the seat and found that it was putting out current. I checked the heating element & found it to be 'open' meaning the element was bad (broken or burnt wire). My solution was to replace the heating pad element. See the next post.

Richard V



What exactly was wrong with your seat heater? I dont know what is wrong with mine. All I know is that if I turn them on I bust a fuse. Was it hard to take the leather off the seat? How long did the whole job take you. Thanks

Chris B
1990 525i





Follow Ups:



[ Follow Ups ] [ 5-series (E34) Message Board ] [ Msg. Board FAQ ]
Questions, comments, or problems, please visit the Roadfly help desk.
Roadfly.com Logo © 1997 - 2017 Jump Internet Inc. All rights reserved.