The complete automotive resource for buyers, sellers, and owners like you.
Car, Truck and SUV Forums at Roadfly
+ Bentley Forums
+ BMW Forums
+ Cadillac Forums
+ Chevrolet Forums
+ Ferrari Forums
+ Jaguar Forums
+ Lamborghini Forums
+ Lotus Forums
+ Mercedes-Benz Forums
+ Maserati Forums
+ MINI Forums
+ Porsche Forums
+ General Discussion
+ Marketplace Forums
Re: instrument cluster problem (archive)

[ Follow Ups ] [ 5-series (E34) Message Board ] [ Msg. Board FAQ ]

Posted by Tom Ahern on November 21, 2000 at 13:49:14:

In Reply to: instrument cluster problem posted by dave h on November 21, 2000 at 00:23:55:


I have followed the instruction from brunos site for fixing the capacitors...
Where do I buy the capacitors and what are they formally caled? Electrolytic, radial caps or what?

Dave


Hi folks,

I am also having troubles with my '91 535i's instrument cluster. Can you tell me the link to "Brunos site" or any other links to a knowledgebase or suggestions on how to fix the problems? My guages are dead and/or jumpy when temps are cold outside; then fuel and temp guages work okay once the car warms up, but tach and speedo still dead or giving bizarre readings.

My trip computer still works fine, so I think it must be some loose connections or bad electronics in the cluster pod.

Thank you in advance for any help!


Follow Ups:



[ Follow Ups ] [ 5-series (E34) Message Board ] [ Msg. Board FAQ ]
Questions, comments, or problems, please visit the Roadfly help desk.
Roadfly.com Logo © 1997 - 2017 Jump Internet Inc. All rights reserved.