The complete automotive resource for buyers, sellers, and owners like you.
Car, Truck and SUV Forums at Roadfly
+ Bentley Forums
+ BMW Forums
+ Cadillac Forums
+ Chevrolet Forums
+ Ferrari Forums
+ Jaguar Forums
+ Lamborghini Forums
+ Lotus Forums
+ Mercedes-Benz Forums
+ Maserati Forums
+ MINI Forums
+ Porsche Forums
+ General Discussion
+ Marketplace Forums
My water pump experiences... (archive)

[ Follow Ups ] [ 5-series (E34) Message Board ] [ Msg. Board FAQ ]

Posted by Paul (at Maximill...) on December 12, 2000 at 17:54:54:

In Reply to: Because of the advice on this board... posted by Kenny on December 12, 2000 at 13:10:06:

I replaced a leaking water pump on an M60 540 Sunday (my first M60 experience) - the one I removed was indeed metal impeller type - but looked like some junk aftermarket piece, compared to the one I installed.

The old one had a stamped / welded thin metal impeller (like you'd get at Pep Boys for your Toyota) , and the new OEM one had a thicker cast metal impeller. I believe the one I removed might have been the original (at 94K miles???) - but I was surprised to see how cheap it looked inside - plus the bearings were toast! (It squealed like Mariah Carey!)

New water pump on - so far no leaks or problems - we'll see.

Perhaps the O rings on the horizontal pipes weren't seated properly when yours was installed. (They come pre-installed on the OE units at least and did require careful alignment upon reinstall of the pump).

HTH

Paul (learning all about others' E34s these days)
Maximillian Importing Co


Follow Ups:



[ Follow Ups ] [ 5-series (E34) Message Board ] [ Msg. Board FAQ ]
Questions, comments, or problems, please visit the Roadfly help desk.
Roadfly.com Logo © 1997 - 2017 Jump Internet Inc. All rights reserved.