The complete automotive resource for buyers, sellers, and owners like you.
Car, Truck and SUV Forums at Roadfly
+ Bentley Forums
+ BMW Forums
+ Cadillac Forums
+ Chevrolet Forums
+ Ferrari Forums
+ Jaguar Forums
+ Lamborghini Forums
+ Lotus Forums
+ Mercedes-Benz Forums
+ Maserati Forums
+ MINI Forums
+ Porsche Forums
+ General Discussion
+ Marketplace Forums
Hey, Greg. The instrument cluster troubleshooting (archive)

[ Follow Ups ] [ 5-series (E34) Message Board ] [ Msg. Board FAQ ]

Posted by Bill R. on December 13, 2000 at 15:13:13:

In Reply to: 1.Thanks for coding plug 2.An injector guess(more) posted by Greg on December 13, 2000 at 11:45:45:

diagram indicates to check the contacts on the coding plug. This is for the early models but it may apply to yours also..


1. I suspected the coding plug but was trying not to think of this. Will check.
2. Your statement matches my observations of the o-rings. The ones that hold injectors into the rail are flexible, while those in manifold are hard to squeeze and can't be reinstalled because they just break into pieces. Just last weekend I removed the fuel rail along with the injectors for a wash. At least one is clicking loudly. The wash device pump failed during first injector cleaning, so I had to buy a new pump. Will resume on the weekend. I'll replace all o-ring and will see if this kills the noise (and the wash restores the pattern, what is primary objective). It is M30B34 of 1991.


Regards,

Greg





Follow Ups:



[ Follow Ups ] [ 5-series (E34) Message Board ] [ Msg. Board FAQ ]
Questions, comments, or problems, please visit the Roadfly help desk.
Roadfly.com Logo © 1997 - 2017 Jump Internet Inc. All rights reserved.