The complete automotive resource for buyers, sellers, and owners like you.
Car, Truck and SUV Forums at Roadfly
+ Bentley Forums
+ BMW Forums
+ Cadillac Forums
+ Chevrolet Forums
+ Ferrari Forums
+ Jaguar Forums
+ Lamborghini Forums
+ Lotus Forums
+ Mercedes-Benz Forums
+ Maserati Forums
+ MINI Forums
+ Porsche Forums
+ General Discussion
+ Marketplace Forums
Need some help with auto trans problems (archive)

[ Follow Ups ] [ 5-series (E34) Message Board ] [ Msg. Board FAQ ]

Posted by R Kieffer on August 02, 2001 at 19:19:17:

For about the past year, I've received the "trans program" error every so often. When the message doesn't display, the transmission runs perfectly, which is about 95% of the time. In a few cases, I've either shut the car off, or disconnected the battery, and everything went back to normal. Here a few weeks ago, trying these things would not reset the error, so I removed the wood trim piece around the shifter, and cleaned the transmission lever position switch and the electronic/manual switch. I also got into the e-box (under the hood in front of the glovebox) and cleaned the contacts for the main power relay, the other relay (?), and two of the large connectors going into the computers. This worked for a while, but I got the error again last night when I got ready to drive the car. So I drove my other car, and when I got in my 535i this morning, everything was back to normal.

During all of this, the tranny shifts fine almost all of the time. The only clue that something seems to be wrong is when it "bangs" the downshifts sometimes when coming to a stop. I tried to pull the codes out this morning, but didn't get any. I've read lots of posts in the archives about this problem, and I think the only things left that've been suggested are to replace the two solenoids in the transmission valve body and maybe the speed sensor. I'm not afraid to do this myself, although the $114 cost for each solenoid isn't easy to take. I am convinced that this is an electical problem since the tranny operates fine 95% of the time. Before delving into higher dollar attempts to fix this problem, I wondered if anyone has had their tranny act similarly and has identified and fixed the problem. If you have, I'd greatly appreciate you taking a couple of minutes to point me in the right direction.

Regards,

Robert J. Kieffer
1991 535i


Follow Ups:



[ Follow Ups ] [ 5-series (E34) Message Board ] [ Msg. Board FAQ ]
Questions, comments, or problems, please visit the Roadfly help desk.
Roadfly.com Logo © 1997 - 2017 Jump Internet Inc. All rights reserved.