The complete automotive resource for buyers, sellers, and owners like you.
Car, Truck and SUV Forums at Roadfly
+ Bentley Forums
+ BMW Forums
+ Cadillac Forums
+ Chevrolet Forums
+ Ferrari Forums
+ Jaguar Forums
+ Lamborghini Forums
+ Lotus Forums
+ Mercedes-Benz Forums
+ Maserati Forums
+ MINI Forums
+ Porsche Forums
+ General Discussion
+ Marketplace Forums
Re: Are you overheating slightly? (archive)

[ Follow Ups ] [ 5-series (E34) Message Board ] [ Msg. Board FAQ ]

Posted by Andrew on August 30, 2001 at 15:55:31:

In Reply to: Are you overheating slightly? posted by Bruno on August 30, 2001 at 15:50:03:


Tempature is and always has stayed at the middle line. It lost a water pump (impeller desintegrated) about a year ago, but no serious overheat. After water pump (and radiator) were replaced, no coolant began to leak for many months later.



If your car is running hot, you will loose coolant.

Having problem with coolant leaking from system on ’92 525i Touring. No hydro-carbons/bubbles/oil detectable in radiator after two tests. Leak-down test done twice – no problem found. No moisture/coolant detectable in exhaust gasses. Very slight staining on one edge of head (between head and block) but general opinion is that this is not coolant. Never smells of coolant. Etc. Been in dealer several times to do tests but unable to find/fix problem. Rest of system seems to be OK. Steadily looses about one quart or so, (enough to get a low coolant light) each 500 to 700 miles.

Is there a high quality “Leak Stop” type product that may be appropriate? I have heard of some in the past.

Any wisdom on this would be appreciated.






Follow Ups:



[ Follow Ups ] [ 5-series (E34) Message Board ] [ Msg. Board FAQ ]
Questions, comments, or problems, please visit the Roadfly help desk.
Roadfly.com Logo © 1997 - 2017 Jump Internet Inc. All rights reserved.