The complete automotive resource for buyers, sellers, and owners like you.
Car, Truck and SUV Forums at Roadfly
+ Bentley Forums
+ BMW Forums
+ Cadillac Forums
+ Chevrolet Forums
+ Ferrari Forums
+ Jaguar Forums
+ Lamborghini Forums
+ Lotus Forums
+ Mercedes-Benz Forums
+ Maserati Forums
+ MINI Forums
+ Porsche Forums
+ General Discussion
+ Marketplace Forums
Re: Help!!! '90 525i radio install (archive)

[ Follow Ups ] [ 5-series (E34) Message Board ] [ Msg. Board FAQ ]

Posted by Mike L on September 03, 2001 at 00:34:15:

In Reply to: Re: Help!!! '90 525i radio install posted by Kyu on August 31, 2001 at 23:53:15:

No, I didn't get extra amp device, but I finally got it installed. Here is what I did using factory amp and speakers and it sounds great:

White } + connected to Left Front wire
White/Black striped } - left disconnected

Grey } + connected to Right Front wire
Grey/Black striped } - left disconnected

Green } + connected to Left Rear wire
Green/Black striped } - left disconnected

Purple } + connected to Right Rear wire
Purple/Black striped} - left disconnected

Black } - connected to Ground (Brown)

Blue } left disconnected

Blue/White striped } connected to white wire for Amp

Red } + connected to red with white stripe

Yellow } + connected to blue with white stripe

good luck,
Mike L


Man I'm having the same problem. I just bought an Aiwa CD receiver from Crutchfield and the wiring harness doens't fit and having all sorts of problems.

Did you get this extra passive amp device? I have that, but still can't get it to work.


I need someone's help in identifying the factory wires in my 1990 525i. I am installing a new Sony AM/FM/CD (CDX-L250_and can't match up the wires. Th unit's features a 45wx4 high power amplifier, RCA preout x1 for extra amplifier. Here are the wires from the deck:

White } +
White/Black striped } - Left Front
Grey } +
Grey/Black striped } - Right Front
Green } +
Green/Black striped } - Left Rear
Purple } +
Purple/Black striped} - Right Rear
Black } - Ground (to metal surface of car
Blue } Ant Rem 0.1A connection for power antenna
Blue/White striped } Amp Rem 0.3A connectionn for amp
Red } + 12v accessory position of ignition switch
Yellow } + 12v power always on

I would like to make this as painless as possible by using the amp. If it's thought that the new unit would sound better, opinions are appreciated.
TIA,
MikeL






Follow Ups:



[ Follow Ups ] [ 5-series (E34) Message Board ] [ Msg. Board FAQ ]
Questions, comments, or problems, please visit the Roadfly help desk.
Roadfly.com Logo © 1997 - 2017 Jump Internet Inc. All rights reserved.