The complete automotive resource for buyers, sellers, and owners like you.
Car, Truck and SUV Forums at Roadfly
+ Bentley Forums
+ BMW Forums
+ Cadillac Forums
+ Chevrolet Forums
+ Ferrari Forums
+ Jaguar Forums
+ Lamborghini Forums
+ Lotus Forums
+ Mercedes-Benz Forums
+ Maserati Forums
+ MINI Forums
+ Porsche Forums
+ General Discussion
+ Marketplace Forums
Re: Happened to me too. Here's possible fix..... (archive)

[ Follow Ups ] [ 5-series (E34) Message Board ] [ Msg. Board FAQ ]

Posted by Warren Gregoire on September 26, 2001 at 11:01:48:

In Reply to: Odometer light posted by Mikel from Spain on September 25, 2001 at 16:27:35:

I discovered that a sharp strike with the palm of my hand to the black molded plastic which forms the instrument "hood" brought it back. It has not recurred since this "disciplinary measure." But when the weather turns cold, I expect it will happen again. My best guess is that the electrical connectors need cleaning or simply being removed and replaced to clear oxidation. There is a great web site with detailed proceedures for doing electrical maintenance.-

http://lennon.csufresno.edu/~jag62

This site does not work properly with my Netscape 4.61 browser, so I use Internet Explorer to access it. The site is about 535i, but these electrical issues should be common to all E34 (and probably all BMWs and most cars.).

Warren


Lo there,

While I was driving my E34 at about 110 kph, suddenly I couldnīt see the odometer numbers. The speedo, tach, temp gauge etc were O.K. 10 seconds later the odometer light came.

Isnīt strange ???

Help please.





Follow Ups:



[ Follow Ups ] [ 5-series (E34) Message Board ] [ Msg. Board FAQ ]
Questions, comments, or problems, please visit the Roadfly help desk.
Roadfly.com Logo © 1997 - 2017 Jump Internet Inc. All rights reserved.