The complete automotive resource for buyers, sellers, and owners like you.
Car, Truck and SUV Forums at Roadfly
+ Bentley Forums
+ BMW Forums
+ Cadillac Forums
+ Chevrolet Forums
+ Ferrari Forums
+ Jaguar Forums
+ Lamborghini Forums
+ Lotus Forums
+ Mercedes-Benz Forums
+ Maserati Forums
+ MINI Forums
+ Porsche Forums
+ General Discussion
+ Marketplace Forums
Re: 535 Running Rough and Rich (archive)

[ Follow Ups ] [ 5-series (E34) Message Board ] [ Msg. Board FAQ ]

Posted by Will D on September 26, 2001 at 11:32:33:

In Reply to: 535 Running Rough and Rich posted by Jeff on September 26, 2001 at 11:22:02:

Looks like you've been busy. Test the fuel pressure and be sure the regulator responds as specified in the service manual (I think it's 2.5 bar at idle, rising to 3.0 bar off-idle). High fuel pressure would tend to make it run rich. Also, you've changed the injectors but how about the cold start valve/injector? Maybe it's leaking all of the time, or if a relay is stuck maybe it's injecting all of the time (check the manual, but you'll want to see if it's powered even after the engine is warmed up).
Really doubt fuel pump has any effect, but the pressure test should tell. If the pressure goes way too high (like +3.5 bar) you may have a restriction in the return line. Be sure of this before replacing the regulator.

Where did you get the fuel line check valve? What's the p/n?


Hello All,

My '89 535 is difficult to start at first. Then when it starts it runs rough and I can smell gas. Then the idle will even out. But then after idling fine for about 2 minutes it starts to run rough again and I there is a "rich" smell coming from the exhaust and you can see that the tailpipes are blackend. Here is what I have done so far to try and fix the problem:
1. Installed the inline "check valve" at the fuel pump.
2. New oxygen sensor
3. New exhaust
4. New Plug wires, Cap and rotor.
5. New Coolant temp switch
6. New Spark Plugs
7. Six new Injectors and O-Rings.
8. Cleaned Idle Control valve.
9 Check computer and no fault codes are stored.

Could it possibly be the fuel pump, idle control valve or fuel pressure regulator? The pump does make a loud buzzing noise, but I cannot see how that could make things run rich. Any help anyone can give me would be much appreciated! Thanks!





Follow Ups:



[ Follow Ups ] [ 5-series (E34) Message Board ] [ Msg. Board FAQ ]
Questions, comments, or problems, please visit the Roadfly help desk.
Roadfly.com Logo © 1997 - 2017 Jump Internet Inc. All rights reserved.