The complete automotive resource for buyers, sellers, and owners like you.
Car, Truck and SUV Forums at Roadfly
+ Bentley Forums
+ BMW Forums
+ Cadillac Forums
+ Chevrolet Forums
+ Ferrari Forums
+ Jaguar Forums
+ Lamborghini Forums
+ Lotus Forums
+ Mercedes-Benz Forums
+ Maserati Forums
+ MINI Forums
+ Porsche Forums
+ General Discussion
+ Marketplace Forums
No pun intended, right Bill? More (archive)

[ Follow Ups ] [ 5-series (E34) Message Board ] [ Msg. Board FAQ ]

Posted by Baer on September 27, 2001 at 10:43:11:

In Reply to: Yes it does, but its a Baer to get to...Its most posted by Bill R. on September 27, 2001 at 10:30:00:

Bill,

This morning my coolant level light came on and the car ran rough on startup, I am going to check the temp sensor and all that you suggest. The car was also blowing a little white smoke too!? Any ideas?

Thanks for your input Bill (and others)

Baer
93 525ia sharked


likely not the ICV anyway based on the symptoms. Check your temp sensor and connections. Also check the throttle positions sensor and connections. Check the air temp sensor and connections and check the Mass air flow sensor and connections. Mainly check and clean the connections. If its a cold and during warmup problems I would check for a bad connection on any of these circuits. Sometimes just unplugging the connector and reconnecting it will clean the connection enough.






Follow Ups:



[ Follow Ups ] [ 5-series (E34) Message Board ] [ Msg. Board FAQ ]
Questions, comments, or problems, please visit the Roadfly help desk.
Roadfly.com Logo © 1997 - 2017 Jump Internet Inc. All rights reserved.