The complete automotive resource for buyers, sellers, and owners like you.
Car, Truck and SUV Forums at Roadfly
+ Bentley Forums
+ BMW Forums
+ Cadillac Forums
+ Chevrolet Forums
+ Ferrari Forums
+ Jaguar Forums
+ Lamborghini Forums
+ Lotus Forums
+ Mercedes-Benz Forums
+ Maserati Forums
+ MINI Forums
+ Porsche Forums
+ General Discussion
+ Marketplace Forums
540 guys(gals) - READ this . . . (archive)

[ Follow Ups ] [ 5-series (E34) Message Board ] [ Msg. Board FAQ ]

Posted by Jason Blitz on October 18, 2001 at 08:29:02:

While in traffic a few days ago, my 94 540's check engine light came on and the idle went to crap, smoke started pouring out of the muffler, and it didn't want to stay running - I did what I could to move the car out of harm's way(there was no shoulder) and pulled it into a gas station 3/4 mile away. By this time there was a loud metal/metal screeching noise coming from the bottom end of the motor & I immediately shut it off.

Granted, the temp gauge was normal, no oil lights etc. - The oil was clean, the coolant was clean and I saw no signs of exterior damage. Anyway, I knew the motor had been replaced & thought could this be a spun main bearing? - It sure sounded like it! - Anyway, after a lengthy tow to the dealer(I towed it there because I thought it might be a bearing & maybe they would make good on a replacement motor-maybe) - My car spent the night there and the dealer called to tell me that there was a valve on the back of the intake that went bad(whew-what a relief). The valve caused my O2 sensors and plugs to foul(this caused the check engine light). Anyway, long story short, They gave me an estimate for $480 in parts and $720 in labor - totalling to $1200!!. My service manager there was really cool about everything and gave me the parts list - he knew I had done quite a bit of mechanical work (transmission & A/C) before and told me that if I had time - maybe I should do it myself - I called BMA & they got me all of the parts for Half of what the dealer wanted - I got OEM too!! I'm waiting for the parts to arrive right now(Fed-Ex) & it's not going to take as long as expected.

While waiting for the wrecker to show up and take me home, the General service manager(not my guy) - started talking to me and insisted that I couldn't do this job myself and I didn't know what I was talking about - whatever. I insisted that I did all of my own complete replacement on suspension, brakes, tranny, diff, A/C work in my driveway - he laughed and said that this was FAR harder than any of that!! He went on to tell me that it would take 5 hrs just to remove the valve - it took 1hr!!!

Trying to scare the customer into service . . . BTW, the whole time I was fretting on the interstate with the smoke coming out of my exhaust there was a new E39 M5 sitting behind me - embarassing, but . . .

Anyway, if this problem happens, check the valve on the back of the intake - I'm not sure how to diagnose the valve itself, but the symptoms are as I described above.

Cheers! I'll post pictures later today!
-Jason Blitz

Thanks Bruno for pointing the way to BMA!!



Follow Ups:



[ Follow Ups ] [ 5-series (E34) Message Board ] [ Msg. Board FAQ ]
Questions, comments, or problems, please visit the Roadfly help desk.
Roadfly.com Logo © 1997 - 2017 Jump Internet Inc. All rights reserved.