The complete automotive resource for buyers, sellers, and owners like you.
Car, Truck and SUV Forums at Roadfly
+ Bentley Forums
+ BMW Forums
+ Cadillac Forums
+ Chevrolet Forums
+ Ferrari Forums
+ Jaguar Forums
+ Lamborghini Forums
+ Lotus Forums
+ Mercedes-Benz Forums
+ Maserati Forums
+ MINI Forums
+ Porsche Forums
+ General Discussion
+ Marketplace Forums
Electrical issues thanks I'll give it a try (archive)

[ Follow Ups ] [ CS (E9) Message Board ] [ Msg. Board FAQ ]

Posted by Dukming on October 15, 2001 at 19:13:16:

In Reply to: Re: Electrical issues posted by coupeless on October 15, 2001 at 17:07:59:

I have only had the car for just under a year and I am not sure about that history but the electrics have been good except for recently fixing the turn indicator repeater.

If the problem started immediately after the repair, I suspect that either one of the grounds was cut, and now the grounding is taking strange alternate paths, or a power wire was jumpered incorrectly. You should ensure that the wiring for the turn signal repair is indeed going to the correct wires.

When you say local grounds--Do you mean in the boot? or whereabouts?

Yes, there's a major common ground point there, probably one under/behind the dash and probably one in the engine bay. Disconnect them and make sure there is no corrosion or oil intrusion on the terminals or on the body/frame at the connection points.




Follow Ups:



[ Follow Ups ] [ CS (E9) Message Board ] [ Msg. Board FAQ ]
Questions, comments, or problems, please visit the Roadfly help desk.
Roadfly.com Logo © 1997 - 2017 Jump Internet Inc. All rights reserved.