The complete automotive resource for buyers, sellers, and owners like you.
Car, Truck and SUV Forums at Roadfly
+ Bentley Forums
+ BMW Forums
+ Cadillac Forums
+ Chevrolet Forums
+ Ferrari Forums
+ Jaguar Forums
+ Lamborghini Forums
+ Lotus Forums
+ Mercedes-Benz Forums
+ Maserati Forums
+ MINI Forums
+ Porsche Forums
+ General Discussion
+ Marketplace Forums
Temp Gauge Above Normal.. help! (archive)

[ Follow Ups ] [ E36 M3 Message Board ] [ Msg. Board FAQ ]

Posted by Patrick FitzGerald on June 12, 2000 at 15:12:49:

Ever since I got back from a road trip a couple weeks ago, I've noticed that my '95 M3a is not performaning properly. It seems to be idling a little lot (around 550 when warmed up) and every now and again (but only in the last 2 weeks), the coolant temp gauge would move above normal when starting up the car. Interestingly, it would return to normal after turning on the A/C. I have also noticed a couple electrical glitches... one time the illumination surrounding the headlamp switch didn't come on at night and then the temp gauge shot up. I turned off the headlamps and the gauge returned to normal, but the backlight wasn't lit. Now it's lit whenever I turn the car on (only for the headlamp switch though), regardless of whether the lamps are actually on or not.

My mechanic ran a voltage test and everything turned out okay. My coolant level seems fine and I got my water pump replaced a few months ago.

Help! It's driving me nuts.

Patrick
'95 M3 Lux


Follow Ups:



[ Follow Ups ] [ E36 M3 Message Board ] [ Msg. Board FAQ ]
Questions, comments, or problems, please visit the Roadfly help desk.
Roadfly.com Logo © 1997 - 2017 Jump Internet Inc. All rights reserved.